<table><tr><td style="">fredrik added inline comments.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D25904">View Revision</a></tr></table><br /><div><strong>INLINE COMMENTS</strong><div><div style="margin: 6px 0 12px 0;"><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D25904#inline-146037">View Inline</a><span style="color: #4b4d51; font-weight: bold;">romangg</span> wrote in <span style="color: #4b4d51; font-weight: bold;">kwinglutils.cpp:1091</span></div>
<div style="margin: 8px 0; padding: 0 12px; color: #74777D;"><p style="padding: 0; margin: 8px;">Can you explain some more? So whenever we change the current viewport call "setDefaultViewport"?</p></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><p style="padding: 0; margin: 8px;">No, the idea is that whoever calls setKWinFramebuffer() would also call setDefaultViewport() to define the viewport that should be used when that framebuffer is bound.</p>
<p style="padding: 0; margin: 8px;">Right now pushRenderTarget() queries GL_VIEWPORT so popRenderTarget() can restore it when the last custom render target is popped. But if we already know what the viewport should be, we don't have to query it from the GL.</p></div></div><br /><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D25904#inline-146035">View Inline</a><span style="color: #4b4d51; font-weight: bold;">romangg</span> wrote in <span style="color: #4b4d51; font-weight: bold;">kwinglutils.h:552</span></div>
<div style="margin: 8px 0; padding: 0 12px; color: #74777D;"><p style="padding: 0; margin: 8px;">I find naming this API something like defaultFramebuffer difficult (as outlined in <a href="https://phabricator.kde.org/D25904#575910" style="background-color: #e7e7e7;
border-color: #e7e7e7;
border-radius: 3px;
padding: 0 4px;
font-weight: bold;
color: black;text-decoration: none;">D25904#575910</a>): because the default framebuffer is not changed when the function is called. The default framebuffer is what this can be changed to but it is not always the default framebuffer. Would <tt style="background: #ebebeb; font-size: 13px;">setBackendFramebuffer</tt> be alright with you? Or <tt style="background: #ebebeb; font-size: 13px;">setBottomFramebuffer</tt>?</p>
<p style="padding: 0; margin: 8px;">I agree the documentation is misleading. I will change it up a bit.</p></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><p style="padding: 0; margin: 8px;">For some reason phabricator didn't warn me that the revision had been updated, so I didn't see that Vlad had already suggested that.</p>
<p style="padding: 0; margin: 8px;">Between those two I think I would prefer setBottomFramebuffer(). But how about setSurfaceFramebuffer()?</p></div></div></div></div></div><br /><div><strong>REPOSITORY</strong><div><div>R108 KWin</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D25904">https://phabricator.kde.org/D25904</a></div></div><br /><div><strong>To: </strong>romangg, KWin<br /><strong>Cc: </strong>fredrik, zzag, kwin, LeGast00n, The-Feren-OS-Dev, sbergeron, jraleigh, fbampaloukas, GB_2, mkulinski, ragreen, jackyalcine, iodelay, crozbo, bwowk, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, hardening, romangg, jensreuterberg, abetts, sebas, apol, ahiemstra, mart<br /></div>