After a short discussion on IRC we concluded that current interface can be changed to be easier to understand:<br><br>Here is a proposal of new naming:<br><br>KisImage::convertImageColorSpace(const KoColorSpace *dstColorSpace, KoColorConversionTransformation::Intent renderingIntent)<br>
converts color space of all the nodes of the image and image&#39;s projection<br><br>KisImage::assingImageProfile(const KoColorProfile *profile)<br>assigns a new profile to every node. <br>^^ this is very disputable, because the user can get unexpected results if his stack contains a mix of different color spaces. Should we leave it?<br>
<br>KisImage::convertRootLayerColorSpace(const KoColorSpace *dstColorSpace, 
KoColorConversionTransformation::Intent renderingIntent)<br>or<br>KisImage::convertProjectionColorSpace(const KoColorSpace *dstColorSpace, 
KoColorConversionTransformation::Intent renderingIntent)<br>converts rootLayer-&gt;projection() only. All the other layers are untouched.<br>
<br>KisImage::assingProjectionProfile(const KoColorProfile *profile)<br>assigns a new profile to rootLayer-&gt;projection() only. All the other layers are 
untouched.<br><br><br clear="all"><br>-- <br>Dmitry Kazakov<br>