Hi, <br>i totally agree with it too,<br>only one thing besides spaces instead of tabs<br><br>maybe we can create a private method in the link importer to add a new link to the transfers list<br><br>something like addLink(const QString &link) or addTransfer(const QString &link)<br>
and always do this :<br> if (!link.contains("://"))<br> link = QString("http://") + link;<br><br> QUrl auxUrl(link);<br> if(!link.isEmpty() && auxUrl.isValid() && m_transfers.indexOf(link) < 0 &&<br>
!auxUrl.scheme().isEmpty() && !auxUrl.host().isEmpty()) {<br> m_transfers << link;<br> }<br><br>just to avoid duplicate code (both slotReadFile and checkClipboard methods could use it).<br>
<br>Please commit it (or should we commit it ? have you got a svn account already ?) <br><br>bye<br><br><div class="gmail_quote">On Sun, Oct 19, 2008 at 12:07 PM, Urs Wolfer <span dir="ltr"><<a href="mailto:uwolfer@kde.org">uwolfer@kde.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">On Friday 17 October 2008 00:17:49 you wrote:<br>
> Hello Urs,<br>
> patch file attached.<br>
<br>
</div>Thanks for the patch. It looks fo me basically okay, but I think Javier should<br>
comment on it. He does the work on our importer.<br>
<br>
Btw, try to use always spaces instead of tabs.<br>
<br>
Bye<br>
<font color="#888888">urs<br>
</font><br>_______________________________________________<br>
Kget mailing list<br>
<a href="mailto:Kget@kde.org">Kget@kde.org</a><br>
<a href="https://mail.kde.org/mailman/listinfo/kget" target="_blank">https://mail.kde.org/mailman/listinfo/kget</a><br>
<br></blockquote></div><br>