<table><tr><td style="">flherne created this revision.<br />flherne added a reviewer: brauch.<br />flherne set the repository for this revision to rKDEVPYTHON KDev-python.<br />Restricted Application added a subscriber: kdevelop-devel.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D3524" rel="noreferrer">View Revision</a></tr></table><br /><div><strong>REVISION SUMMARY</strong><div><p>Rename <tt style="background: #ebebeb; font-size: 13px;">checkForDecorators()</tt> to <tt style="background: #ebebeb; font-size: 13px;">docstringTypeOverride()</tt>, because it doesn't do anything involving decorators. (!)</p>
<div class="remarkup-code-block" style="margin: 12px 0;" data-code-lang="text" data-sigil="remarkup-code-block"><pre class="remarkup-code" style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; padding: 12px; margin: 0; background: rgba(71, 87, 120, 0.08);"></pre></div>
<p>Move the code choosing between class and function types to <tt style="background: #ebebeb; font-size: 13px;">visitCall()</tt>, because it's nothing to do with docstring contents and made the different code paths very hard to follow.</p>
<div class="remarkup-code-block" style="margin: 12px 0;" data-code-lang="text" data-sigil="remarkup-code-block"><pre class="remarkup-code" style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; padding: 12px; margin: 0; background: rgba(71, 87, 120, 0.08);"></pre></div>
<p>Make it return the type it produces, rather than calling <tt style="background: #ebebeb; font-size: 13px;">encounter()</tt> itself, for clarity.</p>
<div class="remarkup-code-block" style="margin: 12px 0;" data-code-lang="text" data-sigil="remarkup-code-block"><pre class="remarkup-code" style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; padding: 12px; margin: 0; background: rgba(71, 87, 120, 0.08);"></pre></div>
<p>Use the new <tt style="background: #ebebeb; font-size: 13px;">isAlias</tt> argument of <tt style="background: #ebebeb; font-size: 13px;">functionForCalled</tt> instead of some code to do the same thing.</p></div></div><br /><div><strong>TEST PLAN</strong><div><p>No intended changes in behaviour.</p>
<p>Passes all existing tests.</p>
<p>TODO: There's one problem that remains unchanged - if we lose the alias state of class objects (e.g. by putting them in a container), they're interpreted and called as instances (i.e. we use <tt style="background: #ebebeb; font-size: 13px;">__call__</tt> instead of the constructor).<br />
Add a test for this.</p></div></div><br /><div><strong>REPOSITORY</strong><div><div>rKDEVPYTHON KDev-python</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D3524" rel="noreferrer">https://phabricator.kde.org/D3524</a></div></div><br /><div><strong>AFFECTED FILES</strong><div><div>duchain/expressionvisitor.cpp<br />
duchain/expressionvisitor.h<br />
duchain/helpers.h</div></div></div><br /><div><strong>EMAIL PREFERENCES</strong><div><a href="https://phabricator.kde.org/settings/panel/emailpreferences/" rel="noreferrer">https://phabricator.kde.org/settings/panel/emailpreferences/</a></div></div><br /><div><strong>To: </strong>flherne, brauch<br /><strong>Cc: </strong>kdevelop-devel<br /></div>