Review Request: Added nested view in the class browser plugin.

Milian Wolff mail at milianw.de
Wed May 23 19:44:28 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104932/#review14093
-----------------------------------------------------------


generally a nice idea I think it could be useful to some people

as you'll see below, there are some issues though, esp. if you open large projects.

then it looks like you are currently not storing the setting (whether flat or nested view is shown) in a config file - please do so, such that the user gets the same view when he reopens kdevelop


plugins/classbrowser/classmodel.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11141>

    please explain this here a bit (i.e. why is this required), and ensure that the viewtype differs from the current viewtype and return early otherwise.



plugins/classbrowser/classwidget.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11142>

    please add a [2] here to make sure this is not changed, or better yet make it a const uint viewTypeActions = 2; and use that in the for loop as well
    
    alternatively put the loop contents into a function and apply that to the two actions manually



plugins/classbrowser/projectfolder.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11143>

    ugh that looks horribly inefficient - please use the project model instead (since that already knows the parent<->children association
    



plugins/classbrowser/projectfolder.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11144>

    remove trailing whitespace



plugins/classbrowser/projectfolder.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11145>

    please put that on a new line:
    
    foo::foo(...)
    : base(...)
    , m_a(...)
    , m_b(...)



plugins/classbrowser/projectfolder.cpp
<http://git.reviewboard.kde.org/r/104932/#comment11147>

    same as above, use the project model to build the tree here


- Milian Wolff


On May 13, 2012, 9:43 a.m., Ghislain Mary wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/104932/
> -----------------------------------------------------------
> 
> (Updated May 13, 2012, 9:43 a.m.)
> 
> 
> Review request for KDevelop.
> 
> 
> Description
> -------
> 
> It enables the user to navigate the project tree and list the classes defined in each directory of the project.
> 
> Some more work would be needed after this to improve the search function. I think we should replace the search lineedit by a "Filter..." action as in the projectmanagerview plugin so it is more consistent. And then when the user enters a filter we should use automatically the flat view because otherwise the user will probably not see the result of his filtering.
> 
> 
> This addresses bug 212583.
>     http://bugs.kde.org/show_bug.cgi?id=212583
> 
> 
> Diffs
> -----
> 
>   plugins/classbrowser/classmodel.h fd1eed5 
>   plugins/classbrowser/classmodel.cpp f9956c6 
>   plugins/classbrowser/classwidget.cpp f5a9517 
>   plugins/classbrowser/projectfolder.h d951a86 
>   plugins/classbrowser/projectfolder.cpp 419cb79 
> 
> Diff: http://git.reviewboard.kde.org/r/104932/diff/
> 
> 
> Testing
> -------
> 
> I used it on the kdevplatform and kdevelop sources and have seen no problem.
> 
> 
> Thanks,
> 
> Ghislain Mary
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20120523/b4e79da3/attachment.html>


More information about the KDevelop-devel mailing list