<html>
 <body>
  <div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
   <table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 solid;">
    <tr>
     <td>
      This is an automatically generated e-mail. To reply, visit:
      <a href="http://git.reviewboard.kde.org/r/109289/">http://git.reviewboard.kde.org/r/109289/</a>
     </td>
    </tr>
   </table>
   <br />





 <pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">I don't really like this patch, it makes things way more complex than they need to be. I'm happy with merging the single slots like you did, it makes a lot of sense, but that's about it. Also I think we can just store and load the values directly to/from the config file, they are all just enums, there's no need to cast them to strings and back. </pre>
 <br />









<p>- Martin</p>


<br />
<p>On March 5th, 2013, 3:37 p.m. UTC, Roman Nazarenko wrote:</p>








<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" style="background-image: url('http://git.reviewboard.kde.org/static/rb/images/review_request_box_top_bg.ab6f3b1072c9.png'); background-position: left top; background-repeat: repeat-x; border: 1px black solid;">
 <tr>
  <td>

<div>Review request for Telepathy.</div>
<div>By Roman Nazarenko.</div>


<p style="color: grey;"><i>Updated March 5, 2013, 3:37 p.m.</i></p>






<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
 <table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: 1px solid #b8b5a0">
 <tr>
  <td>
   <pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">Adds exclusive actions group for contact list grouping.
Added enumerated action groups, so we could easily convert checked grouped action into appearance modes. 
Those groups also allow us to replace onFullView/onNormalView slots with one onAppearanceChanged(int), so we can reduce number of manual signal-slot connections (and improve readability and maintainability). 

Also moved (config file option name <-> widget text <-> mode enumerator) relations for exclusive action groups into separate static class MenuConfig, so we can avoid manual relations tracking.</pre>
  </td>
 </tr>
</table>




<div style="margin-top: 1.5em;">
 <b style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Bugs: </b>


 <a href="http://bugs.kde.org/show_bug.cgi?id=279023">279023</a>


</div>


<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">

 <li>CMakeLists.txt <span style="color: grey">(5802d32)</span></li>

 <li>action-group-enumerated.h <span style="color: grey">(PRE-CREATION)</span></li>

 <li>action-group-enumerated.cpp <span style="color: grey">(PRE-CREATION)</span></li>

 <li>contact-list-widget.h <span style="color: grey">(ab2191c)</span></li>

 <li>contact-list-widget.cpp <span style="color: grey">(f931913)</span></li>

 <li>main-widget.h <span style="color: grey">(d72c970)</span></li>

 <li>main-widget.cpp <span style="color: grey">(778c71e)</span></li>

</ul>

<p><a href="http://git.reviewboard.kde.org/r/109289/diff/" style="margin-left: 3em;">View Diff</a></p>







  </td>
 </tr>
</table>








  </div>
 </body>
</html>