<html>
<body>
<div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
<table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 solid;">
<tr>
<td>
This is an automatically generated e-mail. To reply, visit:
<a href="http://git.reviewboard.kde.org/r/105515/">http://git.reviewboard.kde.org/r/105515/</a>
</td>
</tr>
</table>
<br />
<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" style="background-image: url('http://git.reviewboard.kde.org/media/rb/images/review_request_box_top_bg.png'); background-position: left top; background-repeat: repeat-x; border: 1px black solid;">
<tr>
<td>
<div>Review request for Telepathy.</div>
<div>By George Kiagiadakis.</div>
<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: 1px solid #b8b5a0">
<tr>
<td>
<pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">Being annoyed by the fact that the presence applet shows the AddContactDialog as a modal dialog (making plasma unusable in the meantime), I decided to move the contact subscription logic inside the dialog and therefore eliminate code duplication between the applet and the CL as well as make it easy to use the dialog in a non-modal way.
This patch also adds the KTP_NO_EXPORT macro, which we should start using to hide private symbols and prepare the library for frameworks.
Shortlog:
George Kiagiadakis (9):
AddContactDialog: Move function implementations inside the KTp namespace
ktp-export.h: Add KTP_NO_EXPORT macro
AddContactDialog: Move the contact creation logic from the presence applet & CL inside the dialog
AddContactDialog: Remove public accessors for account and screen name
AddContactsDialog: Use QComboBox::setModel() instead of manually populating it with entries from the model
AddContactDialog: Error out if the user did not specify a contact name
AddContactDialog: kDebug++
AddContactDialog: Use KMessageBox::sorry() instead of error() and enhance the strings
AddContactDialog: Attribute copyright to myself</pre>
</td>
</tr>
</table>
<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Testing </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: 1px solid #b8b5a0">
<tr>
<td>
<pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">The dialog still seems to work as expected</pre>
</td>
</tr>
</table>
<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">
<li>KTp/Widgets/add-contact-dialog.h <span style="color: grey">(cc65aa3f6a94884a83bd058e876cecc5e996fb85)</span></li>
<li>KTp/Widgets/add-contact-dialog.cpp <span style="color: grey">(dfbd9aac870a4d82953820fa4feb28e3af9d7f3d)</span></li>
<li>KTp/ktp-export.h <span style="color: grey">(909c3ca9f1b8ddaed28c0fc15b2537da2a843760)</span></li>
</ul>
<p><a href="http://git.reviewboard.kde.org/r/105515/diff/" style="margin-left: 3em;">View Diff</a></p>
</td>
</tr>
</table>
</div>
</body>
</html>