Review Request: Block/Unblock feature in ktp-text-ui module.

Martin Klapetek martin.klapetek at gmail.com
Fri Mar 30 10:04:21 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104407/#review12005
-----------------------------------------------------------



app/chat-window.cpp
<http://git.reviewboard.kde.org/r/104407/#comment9479>

    Theoretically if you created setBlockDisabled(bool), you could connect directly to it instead of creating this helper slot. Not a big issue, just a bit useless code.
    
    In fact the naming is not that good. You toggle the button entirely, not just enable/disable it.
    
    So correctly it should be toggleBlockButton(bool contactIsBlocked). That way you can remove this slot completely.



app/chat-window.cpp
<http://git.reviewboard.kde.org/r/104407/#comment9480>

    As pointed above, this slot is named incorrectly as it does not enable/disable block button, but changes it to something different, hence it should be named "toggleBlockButton(bool contactIsBlocked)" or something like that.
    
    Furthermore there's a special class exactly for this - KDualAction - which handles this for you. Try looking at it, but it's ok if you leave it like this.
    
    http://api.kde.org/4.x-api/kdelibs-apidocs/kdeui/html/classKDualAction.html



lib/chat-widget.cpp
<http://git.reviewboard.kde.org/r/104407/#comment9478>

    I'm not a native english speaker but this string seems weird to me. "%1 is not blocked anymore"? Seems more 'human' to me.
    
    However that's just my opinion and if no other will comment on this, ignore it.


- Martin Klapetek


On March 29, 2012, 11:46 p.m., Ahmed Ibrahim wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/104407/
> -----------------------------------------------------------
> 
> (Updated March 29, 2012, 11:46 p.m.)
> 
> 
> Review request for Telepathy and Daniele Elmo Domenichelli.
> 
> 
> Description
> -------
> 
> Added Block/Unblock contact button to the KActionCollection of the ktp-text-ui.
> Added also code that will help in displaying blocking/unblocking actions to the user in the ChatView.
> 
> 
> This addresses bug 292402.
>     http://bugs.kde.org/show_bug.cgi?id=292402
> 
> 
> Diffs
> -----
> 
>   app/chat-window.h 8ee4463 
>   app/chat-window.cpp 75dd968 
>   app/chatwindow.rc f65fbd1 
>   app/main.cpp d76ce04 
>   lib/channel-contact-model.h 41d5d84 
>   lib/channel-contact-model.cpp d731322 
>   lib/chat-widget.h e1efbbb 
>   lib/chat-widget.cpp bb1f5ef 
> 
> Diff: http://git.reviewboard.kde.org/r/104407/diff/
> 
> 
> Testing
> -------
> 
> Blocked a contact and found that is blocked in another IM client and had other opened tabs and the button was changing according to the user's block state 
> 
> 
> Thanks,
> 
> Ahmed Ibrahim
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-telepathy/attachments/20120330/4816ab14/attachment.html>


More information about the KDE-Telepathy mailing list