[Phonon][Patch] add a method to get the current frame number

Sylvain "Skarsnik" Colinet scolinet at gmail.com
Sat Mar 29 12:35:59 GMT 2008


On Sat, Mar 29, 2008 at 12:15 PM, Matthias Kretz <kretz at kde.org> wrote:

> On Friday 28 March 2008, Tanguy Krotoff wrote:
> > On Thu, Mar 20, 2008 at 7:40 PM, Matthias Kretz <kretz at kde.org> wrote:
> > >  Perhaps it should be called currentVideoFrame() since there are also
> > > audio frames (just 48000 per second instead of ~25). And I omitted
> > > "Number" to not make the function name too long.
> >
> > I think term Number is good since currentVideoFrame() can "mean"
> something
> > else like:
> > qint64 videoFrameId = obj->currentVideoFrame();
> > or
> > VideoFrame videoFrame = obj->currentVideoFrame();
> > videoFrame->size();
>

Yes that why I choose this long name


> > Why not Nb?
> > Number is used by Qt API, not Nb
> > cf http://doc.trolltech.com/main-snapshot/functions.html
> >
> > >  Other functions that could be added later are:
> > >  qint64 videoFrameCount()
> > >  void seekToVideoFrame(qint64)
> >
> > seekToVideoFrameNumber()
> > to make it symmetric, even a longer name :/
>
> The rule is to not use abreviations in class/function names. And with
> 'Number'
> it really gets long. More general idea:
>
> enum Timecode
> {
>    SmpteTimecode,
>    VideoFrameNumber,
>    AudioFrameNumber,
>    Microseconds,
>    Milliseconds,
>    Seconds
> };
>
> ok, that's pushing it a bit, but I just tried to come up with a little
> more
> than two entries :-)
>
> class MediaObject
> {
> ...
>    <some type> currentTime(Timecode) const;
>    <some type> totalTime(Timecode) const;
>    void seek(Timecode, <some type>);
>    <some type> convertTimecodeTo(Timecode, <some type>);
> ...
> };
>
> Where <some type> could either be quint64, QVariant or a more
> specialized/simple class (don't know SMPTE well enough).
>
>
>
I like the enum idea.I will try to rewrite the pos thing like this. maybe a
setDefaultTimecode()
can be usefull?
For the binary compatibiliy prob, is there a document that explain thing to
do or not, to keep
compatibility?

Thanks for comment.

-- 
Sylvain "Skarsnik" Colinet

Victory was near but the power of the ring couldn't be undone
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-multimedia/attachments/20080329/bcef2fe7/attachment.htm>
-------------- next part --------------
_______________________________________________
kde-multimedia mailing list
kde-multimedia at kde.org
https://mail.kde.org/mailman/listinfo/kde-multimedia


More information about the kde-multimedia mailing list