<br><br><div class="gmail_quote">2008/12/8 Luka Renko <span dir="ltr">&lt;<a href="mailto:lure@kubuntu.org">lure@kubuntu.org</a>&gt;</span><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div class="Ih2E3d">On Monday 08 December 2008 18:14:10 Andi Clemens wrote:<br>
&gt; enum ButtonStyle<br>
&gt; {<br>
&gt; ButtonsLeft,<br>
&gt; ButtonsRight,<br>
&gt; ButtonsBelow,<br>
&gt; NoButtons<br>
&gt; }<br>
<br>
</div>I like this. I would implement Right, Left and NoButtons for now, we can add<br>
more later.<br>
Maybe we should name it ControlButtons?<br>
<div class="Ih2E3d"><br>
&gt; enum I_DONT_KNOW_A_GOOD_NAME_NOW<br>
&gt; {<br>
&gt; AutoLoad,<br>
&gt; AllowRaw<br>
&gt; }<br>
&gt;<br>
&gt; and put those two into the ctor<br>
&gt;<br>
&gt; ImagesList(parent, ButtonStyle, UNKNOWN_NAME :-))<br>
<br>
</div>I agree with Aurélien here: both options can be moved out of constructor. This<br>
would then look something like this:<br>
<br>
 &nbsp; imgList = new ImagesList(parent, ButtonsLeft);<br>
 &nbsp; imgList-&gt;setAllowRaw(true);<br>
 &nbsp; imgList-&gt;loadImagesFromCurrentSelection();<br>
<br>
I think autoLoad was anyhow just loading from current selection, therefore<br>
giving it more obvious name is better.<br>
The only requirement is that setAllowRaw() is called first, otherwise they<br>
would not be loaded, but I think this should be pretty obvious.<br>
<br>
If you are fine with above proposal, I am fine to make this change and update<br>
all plugins in extragear/graphics/kipi-plugins that use it. I anyway need<br>
proper change for SmugMug plugin, so I am more than interested to have this<br>
sooner than later. Review from Andi (and others) would still be appreciated.<br>
;-)</blockquote><div>&nbsp;</div><div>Agree for me.<br><br>I plan, to release sunday next KDE4 beta of kipi-plugins and digiKam. It will be fine to prepare your plugin for this date in svn<br><br>Best<br><br>Gilles</div></div>
<br>