<table><tr><td style="">ahmadsamir added a comment.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D29385">View Revision</a></tr></table><br /><div><div><blockquote style="border-left: 3px solid #8C98B8;
color: #6B748C;
font-style: italic;
margin: 4px 0 12px 0;
padding: 8px 12px;
background-color: #F8F9FC;">
<div style="font-style: normal;
padding-bottom: 4px;">In <a href="https://phabricator.kde.org/D29385#664552" style="background-color: #e7e7e7;
border-color: #e7e7e7;
border-radius: 3px;
padding: 0 4px;
font-weight: bold;
color: black;text-decoration: line-through;">D29385#664552</a>, <a href="https://phabricator.kde.org/p/dfaure/" style="
border-color: #f1f7ff;
color: #19558d;
background-color: #f1f7ff;
border: 1px solid transparent;
border-radius: 3px;
font-weight: bold;
padding: 0 4px;">@dfaure</a> wrote:</div>
<div style="margin: 0;
padding: 0;
border: 0;
color: rgb(107, 116, 140);"><p>-void KIO::OpenUrlJob::setRunFlags(KIO::ApplicationLauncherJob::RunFlags runFlags)<br />
+void KIO::OpenUrlJob::setDeleteTemporaryFile(bool b)</p>
<p>The more I think about it, the least I like the use of flags here.</p>
<ol class="remarkup-list">
<li class="remarkup-list-item">they are from the wrong class as Kai-Uwe pointed out, but more importantly:</li>
<li class="remarkup-list-item">the other bool setters here are for unrelated concerns, better keep them separate.
<br /><br />
Are we doing lineEdit->setDragEnabled(true); lineEdit->setClearButtonEnabled(true); lineEdit->setReadOnly(true); or are we doing lineEdit->setFlags(QLineEdit::DragEnabled | QLineEdit::ClearButtonEnabled | QLineEdit::ReadOnly)?</li>
</ol></div>
</blockquote>
<p>I vote:<br />
lineEdit->setDragEnabled(true); lineEdit->setClearButtonEnabled(true); lineEdit->setReadOnly(true);<br />
it's:</p>
<ul class="remarkup-list">
<li class="remarkup-list-item">more readable, and easier to use (similar methods are used through out Qt code)</li>
<li class="remarkup-list-item">avoids the case you talked about, of the user setting nonsensical, from the code POV, flags.</li>
</ul>
<p>I was too slow working my way through this short story^W^W review, so I've gathered my other comments (mostly code style, docs changes...etc) in a diff, that I'll submit shortly.</p></div></div><br /><div><strong>REPOSITORY</strong><div><div>R241 KIO</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D29385">https://phabricator.kde.org/D29385</a></div></div><br /><div><strong>To: </strong>dfaure, ahmadsamir, broulik, meven, kossebau, davidedmundson, nicolasfella, svuorela<br /><strong>Cc: </strong>feverfew, kde-frameworks-devel, LeGast00n, cblack, michaelh, ngraham, bruns<br /></div>