<table><tr><td style="">hallas added inline comments.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D21235">View Revision</a></tr></table><br /><div><strong>INLINE COMMENTS</strong><div><div style="margin: 6px 0 12px 0;"><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D21235#inline-143042">View Inline</a><span style="color: #4b4d51; font-weight: bold;">bruns</span> wrote in <span style="color: #4b4d51; font-weight: bold;">fstabhandling.cpp:301</span></div>
<div style="margin: 8px 0; padding: 0 12px; color: #74777D;"><p style="padding: 0; margin: 8px;">The API is totally awkward.</p>

<p style="padding: 0; margin: 8px;">You end up with something significantly cleaner when you create a new class for it:</p>

<div class="remarkup-code-block" style="margin: 12px 0;" data-code-lang="text" data-sigil="remarkup-code-block"><pre class="remarkup-code" style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; padding: 12px; margin: 0; background: rgba(71, 87, 120, 0.08);">QStringMultiHash m_mtabCache;
QHash<QString, QString> m_mtabFstypeCache;
bool m_mtabCacheValid;</pre></div>

<p style="padding: 0; margin: 8px;">and make the parser a member function.</p>

<p style="padding: 0; margin: 8px;">Then instantiate the class for the fuseiso case and for the globalFstabCache.</p></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><p style="padding: 0; margin: 8px;">Yeah, I agree - it isn't the prettiest of code :D My main reasoning for doing it like this was to make the change as small as possible. But, let me take a stab at refactoring it a bit and push a new commit.</p></div></div></div></div></div><br /><div><strong>REPOSITORY</strong><div><div>R245 Solid</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D21235">https://phabricator.kde.org/D21235</a></div></div><br /><div><strong>To: </strong>hallas, bruns, ngraham<br /><strong>Cc: </strong>broulik, kde-frameworks-devel, LeGast00n, GB_2, michaelh, ngraham, bruns<br /></div>