<table><tr><td style="">jglogowski marked an inline comment as done.<br />jglogowski added inline comments.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D21249">View Revision</a></tr></table><br /><div><strong>INLINE COMMENTS</strong><div><div style="margin: 6px 0 12px 0;"><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D21249#inline-119383">View Inline</a><span style="color: #4b4d51; font-weight: bold;">elvisangelaccio</span> wrote in <span style="color: #4b4d51; font-weight: bold;">kfilewidget.cpp:132</span></div>
<div style="margin: 8px 0; padding: 0 12px; color: #74777D;"><p style="padding: 0; margin: 8px;">Nitpick: I'd make <tt style="background: #ebebeb; font-size: 13px;">filter</tt> the first parameter. And we usually don't use <tt style="background: #ebebeb; font-size: 13px;">const boll</tt> in signatures, but just <tt style="background: #ebebeb; font-size: 13px;">bool</tt>.</p>
<p style="padding: 0; margin: 8px;"><tt style="background: #ebebeb; font-size: 13px;">bUpdate</tt> doesn't tell the reader what this variable is used for. How about calling it <tt style="background: #ebebeb; font-size: 13px;">updateCurrentFilter</tt> or similar?</p></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><p style="padding: 0; margin: 8px;">Kind of Done.</p></div></div><br /><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D21249#inline-119426">View Inline</a><span style="color: #4b4d51; font-weight: bold;">dfaure</span> wrote in <span style="color: #4b4d51; font-weight: bold;">kfilewidget.cpp:2463</span></div>
<div style="margin: 8px 0; padding: 0 12px; color: #74777D;"><p style="padding: 0; margin: 8px;">Is the bUpdate bool necessary?</p>
<p style="padding: 0; margin: 8px;">Without it, we'd call setCurrentFilter(currentFilter()) which should be a no-op, right?</p>
<p style="padding: 0; margin: 8px;">Alternatively, the method could return a QString, and the (second) caller could call setCurrentFilter.</p>
<p style="padding: 0; margin: 8px;">I just don't like a method that's sometimes a getter and sometimes a setter (basically).</p></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><blockquote style="border-left: 3px solid #a7b5bf; color: #464c5c; font-style: italic; margin: 4px 0 12px 0; padding: 4px 12px; background-color: #f8f9fc;"><p style="padding: 0; margin: 8px;">Is the bUpdate bool necessary?</p></blockquote>
<div class="remarkup-code-block" style="margin: 12px 0;" data-code-lang="text" data-sigil="remarkup-code-block"><pre class="remarkup-code" style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; padding: 12px; margin: 0; background: rgba(71, 87, 120, 0.08);">void KFileFilterCombo::setCurrentFilter(const QString &filter)
{
setCurrentIndex(d->m_filters.indexOf(filter));
emit filterChanged();
}</pre></div>
<p style="padding: 0; margin: 8px;">filterChanged will unconditionally start the "cycle", which will set the wrong filter.<br />
Wanted to keep my changes more local.</p>
<blockquote style="border-left: 3px solid #a7b5bf; color: #464c5c; font-style: italic; margin: 4px 0 12px 0; padding: 4px 12px; background-color: #f8f9fc;"><p style="padding: 0; margin: 8px;">Alternatively, the method could return a QString, and the (second) caller could call setCurrentFilter.<br />
I just don't like a method that's sometimes a getter and sometimes a setter (basically).</p></blockquote>
<p style="padding: 0; margin: 8px;">Also had that. It "felt" strange, but I don't care much.</p></div></div></div></div></div><br /><div><strong>REPOSITORY</strong><div><div>R241 KIO</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D21249">https://phabricator.kde.org/D21249</a></div></div><br /><div><strong>To: </strong>jglogowski, Frameworks, ngraham, dfaure<br /><strong>Cc: </strong>elvisangelaccio, ngraham, michaelweghorn, kde-frameworks-devel, michaelh, bruns<br /></div>