<table><tr><td style="">mpyne requested changes to this revision.<br />mpyne added a comment.<br />This revision now requires changes to proceed.
</td><a style="text-decoration: none; padding: 4px 8px; margin: 0 8px 8px; float: right; color: #464C5C; font-weight: bold; border-radius: 3px; background-color: #F7F7F9; background-image: linear-gradient(to bottom,#fff,#f1f0f1); display: inline-block; border: 1px solid rgba(71,87,120,.2);" href="https://phabricator.kde.org/D6672" rel="noreferrer">View Revision</a></tr></table><br /><div><div><p>AFAICT we do need to maintain BIC here even for private ctors.  The inline comment has more detail.  Other than that and with using a flag enum instead of a <tt style="background: #ebebeb; font-size: 13px;">bool</tt> I like the patch and the approach, and how you've maintained the same basic approach the existing code does.</p>

<p>I would lean towards also providing the convenience accessor in <tt style="background: #ebebeb; font-size: 13px;">KAboutLicense</tt> for the orLater flag, but it is already exposed back to the user so perhaps it wouldn't add enough extra detail to be worth it.</p></div></div><br /><div><strong>INLINE COMMENTS</strong><div><div style="margin: 6px 0 12px 0;"><div style="border: 1px solid #C7CCD9; border-radius: 3px;"><div style="padding: 0; background: #F7F7F7; border-color: #e3e4e8; border-style: solid; border-width: 0 0 1px 0; margin: 0;"><div style="color: #74777d; background: #eff2f4; padding: 6px 8px; overflow: hidden;"><a style="float: right; text-decoration: none;" href="https://phabricator.kde.org/D6672#inline-27579" rel="noreferrer">View Inline</a><span style="color: #4b4d51; font-weight: bold;">kaboutdata.h:291</span></div>
<div style="font: 11px/15px "Menlo", "Consolas", "Monaco", monospace; white-space: pre-wrap; clear: both; padding: 4px 0; margin: 0;"><div style="padding: 0 8px; margin: 0 4px; background: rgba(251, 175, 175, .7);">    <span class="n">explicit</span> <span class="n">KAboutLicense</span><span class="p">(</span><span style="color: #aa4000">enum</span> <span class="n">KAboutLicense</span><span style="color: #aa2211">::</span><span class="n">LicenseKey</span> <span class="n">licenseType</span><span class="p">,</span> <span style="color: #aa4000">const</span> <span class="n">KAboutData</span> <span style="color: #aa2211">*</span><span class="n">aboutData<span class="bright"></span></span><span class="bright"></span><span class="p"><span class="bright">);</span></span>
</div><div style="padding: 0 8px; margin: 0 4px; background: rgba(151, 234, 151, .6);">    <span class="n">explicit</span> <span class="n">KAboutLicense</span><span class="p">(</span><span style="color: #aa4000">enum</span> <span class="n">KAboutLicense</span><span style="color: #aa2211">::</span><span class="n">LicenseKey</span> <span class="n">licenseType</span><span class="p">,</span> <span style="color: #aa4000">const</span> <span class="n">KAboutData</span> <span style="color: #aa2211">*</span><span class="n">aboutData<span class="bright"></span></span><span class="bright"></span><span class="p"><span class="bright">,</span></span>
</div><div style="padding: 0 8px; margin: 0 4px; background: rgba(151, 234, 151, .6);">                           <span style="color: #aa4000">bool</span> <span class="n">orLater</span> <span style="color: #aa2211">=</span> <span style="color: #304a96">false</span><span class="p">);</span>
</div><div style="padding: 0 8px; margin: 0 4px; ">    <span style="color: #74777d">/**</span>
</div></div></div>
<div style="margin: 8px 0; padding: 0 12px;"><p style="padding: 0; margin: 8px;">Regarding the BIC question, we do consider this BIC, even though it is SC thanks to the default param.  Instead a second ctor is needed with this signature (and w/out the default param to avoid C++ errors), with a comment to merge with the existing ctor in KF6.</p>

<p style="padding: 0; margin: 8px;">Please see <a href="https://community.kde.org/Policies/Binary_Compatibility_Issues_With_C%2B%2B" class="remarkup-link" target="_blank" rel="noreferrer">https://community.kde.org/Policies/Binary_Compatibility_Issues_With_C%2B%2B</a>, you can search for "extending a function with another parameter" to see what I'm referring to.  This guidance applies to methods of any type, even private methods.</p>

<p style="padding: 0; margin: 8px;">However, I think the <tt style="background: #ebebeb; font-size: 13px;">orLater</tt> param would be more understandable as an enum flag, in the same way we modified our APIs in KDE4 and KF5 to try and avoid <tt style="background: #ebebeb; font-size: 13px;">bool</tt> params.  This would be especially important for readability if we do start to support things like license exceptions, you can imagine future calls would then look like <tt style="background: #ebebeb; font-size: 13px;">...->addLicense(KAboutLicense::LGPL_V3, true, KAboutLicense::ExceptionGeneratedCodeUse);</tt> and then wonder what the <tt style="background: #ebebeb; font-size: 13px;">true</tt> was for.</p></div></div></div></div></div><br /><div><strong>REPOSITORY</strong><div><div>R244 KCoreAddons</div></div></div><br /><div><strong>REVISION DETAIL</strong><div><a href="https://phabricator.kde.org/D6672" rel="noreferrer">https://phabricator.kde.org/D6672</a></div></div><br /><div><strong>To: </strong>sitter, sebas, mpyne<br /><strong>Cc: </strong>Frameworks<br /></div>