D27133: kconfig_compiler : generate kconfig settings with subgroup

Cyril Rossi noreply at phabricator.kde.org
Mon Mar 2 16:24:51 GMT 2020


crossi planned changes to this revision.
crossi added a comment.


  Thanks for your comments.
  
  A new attribute to the group element would be more readable and easier to edit/maintain.
  
  To generate code like :
  
    KConfig config;
    KConfigGroup generalGroup( &config, "General" );
    KConfigGroup colorsGroup = config.group( "Colors" );
  
  kcfg will look like :
  
    <group name="Colors" parentGroup="General">
        <entry name="Foo" type="Bool">
            <default>true</default>
        </entry>
    </group>
  
  Currently, I only need one level of subgroup, let's keep it simple and drop the group separator stuff for the moment.

REPOSITORY
  R237 KConfig

REVISION DETAIL
  https://phabricator.kde.org/D27133

To: crossi, ervin, dfaure, #frameworks
Cc: meven, kde-frameworks-devel, LeGast00n, cblack, GB_2, michaelh, ngraham, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20200302/3d816810/attachment.html>


More information about the Kde-frameworks-devel mailing list