D13368: play_piano, lay down UI of the activity and implement working logic and levels.

Johnny Jazeix noreply at phabricator.kde.org
Thu Jun 7 06:13:32 UTC 2018


jjazeix added inline comments.

INLINE COMMENTS

> MultipleStaff.qml:162
> +            noteNotation = clef + noteName
> +        console.log(noteNotation)
> +        for(var i = 0; i < notesDetails.length; i++) {

if you don't need anymore the logs,  you can remove them

> MultipleStaff.qml:138
> +        var notesDetails = NoteNotations.get()
> +        var clef = background.clefType === 'treble' ? "Treble" : "Bass"
> +        var noteNotation

can you name the clefType directly "Treble" and "Bass"?

> PlayPiano.qml:124
> +            property alias iAmReady: iAmReady
> +            property string mode: "easy"
>          }

is there a better name than "easy"/"hard"?

> PlayPiano.qml:281
> +            undoButtonVisible: true
> +            changeAccidentalStyleButtonVisible: [6, 11].indexOf(items.bar.level) != -1
> +            clefButtonVisible: false

All the options should be invisible by default (in OptionsRow.qml) and there and in piano_composition, you should set them to the values you want

REPOSITORY
  R2 GCompris

REVISION DETAIL
  https://phabricator.kde.org/D13368

To: amankumargupta, #gcompris_activities
Cc: jjazeix, kde-edu, #gcompris_activities, himanshuvishwakarma, harrymecwan, ganeshredcobra, nityanandkumar, echarruau, rahulyadav, narvaez, scagarwal, apol, timotheegiet, hkaelberer, bcoudoin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20180607/62bb088f/attachment.html>


More information about the kde-edu mailing list