Review Request 115449: [PATCH] Removes gradient in statistics and makes it more intuitive. Fixes BUG:#266368

Andreas Cord-Landwehr cordlandwehr at kde.org
Mon Feb 3 20:42:20 UTC 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/115449/#review48857
-----------------------------------------------------------


First of a short review of the coding style: Please take care to not use tabulators but 4-space indentations as well as proper spacing around operators, and variable naming.
Parley should mainly follow the KDElibs coding styles as explained here: http://techbase.kde.org/Policies/Kdelibs_Coding_Style


src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34491>

    use "qreal"



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34496>

    rename to xPosition



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34483>

    * add spaces around operators
    * use camel cased variables
    * maybe something like barElementWidth would be mor appropriate as variable name?



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34484>

    remove whitespace



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34485>

    * use camel case variable names
    * maybe barElement would better explain this variable?



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34502>

    * camel case this variable
    * maybe rename to elementBarPath?



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34486>

    * use camel case variable names
    * maybe barElementBorder would be better?



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34487>

    add spaces around operators



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34495>

    this formula needs explenation (in particular, where are the values 7 and 35 coming from?)



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34488>

    add spaces: "if (i != 0) {"



src/statistics/lessonstatistics.cpp
<https://git.reviewboard.kde.org/r/115449/#comment34489>

    wrong indentation


- Andreas Cord-Landwehr


On Feb. 3, 2014, 6:06 p.m., Amarvir Singh wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/115449/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2014, 6:06 p.m.)
> 
> 
> Review request for KDE Edu.
> 
> 
> Repository: parley
> 
> 
> Description
> -------
> 
> This closes the mentioned bug, as it removes the gradient in learning statistics and uses solid color.
> It also makes it even more intuitive for the user, as it uses a single color for all the grades with different alpha values, increasing as grades increase. Thus darker shades mean higher grades.
> Also the default grade colors have been changed to be the same, except grade 0.
> 
> Fixes BUG:#266368
> 
> 
> Diffs
> -----
> 
>   src/settings/parley.kcfg 34bfd98 
>   src/statistics/lessonstatistics.cpp e09cff8 
> 
> Diff: https://git.reviewboard.kde.org/r/115449/diff/
> 
> 
> Testing
> -------
> 
> Tested the default button, and tested for all grades. Still intuitive and working.
> 
> 
> Thanks,
> 
> Amarvir Singh
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20140203/af3b6904/attachment-0001.html>


More information about the kde-edu mailing list