Review Request: Don't append "0-" when dragging and dropping from trash

David Faure faure at kde.org
Wed Nov 21 14:42:32 GMT 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/105078/#review22311
-----------------------------------------------------------

Ship it!


Starting to look good :-)
Just one minor code issue, and then commit.

I see that the trash.protocol change isn't included, we'll look at that separately? (probably a good idea)


kioslave/trash/kio_trash.cpp
<http://git.reviewboard.kde.org/r/105078/#comment17146>

    Can you rename it to fileDisplayName, if that's what it's used for? This will make it more consistent with listDir.
    
    Even better: move this to a common helper file-static function in the .cpp file.
    Input: relativePath, fileId
    Output: fileDisplayName
    => static QString makeDisplayName(const QString& relativePath, const QString& fileId) { ... }


- David Faure


On Nov. 16, 2012, 2:19 a.m., Michael Reeves wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/105078/
> -----------------------------------------------------------
> 
> (Updated Nov. 16, 2012, 2:19 a.m.)
> 
> 
> Review request for KDE Runtime.
> 
> 
> Description
> -------
> 
> This patch makes drag-and-drop and cut/paste from trash preserve the orginal filename instead of appending "0-".
> 
> 
> This addresses bug 183403.
>     http://bugs.kde.org/show_bug.cgi?id=183403
> 
> 
> Diffs
> -----
> 
>   kioslave/trash/kio_trash.cpp 138bab3 
> 
> Diff: http://git.reviewboard.kde.org/r/105078/diff/
> 
> 
> Testing
> -------
> 
> I have used the modified io_trash module on my machine since before the KDE 4.8 release and still use it under KDE 4.8.3.
> 
> 
> Thanks,
> 
> Michael Reeves
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20121121/a51d478b/attachment.htm>


More information about the kde-core-devel mailing list