<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span class=""><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
1) We are planning to alpha-release LevelOfDetail and Animation functionality soon for users to test. And we cannot base this<br>
version on Frameworks, because the latter one has no decent tablet support on Linux (Qt5 makes the line look jittery and we have no<br>
decision yet how to fix that). So we cannot merge it in atm.<br>
</blockquote>
<br></span>
You _have_ to. You can't go on building the animation branch against 2.9<br>
and expect to be able to merge it to master later on. There will be too<br>
many changes, not just whitespace cleanups. It's a pity that tablet support<br>
isn't fixed yet, but that's not a reason not to move feature development<br>
to the master/kf5/qt5 branch. We'll have to make sure tablet support is good again anyway.<span class=""><br></span></blockquote><div><br></div><div>Well, I can merge animation into frameworks and continue developing in animation. At least I think I can. Then we could release alpha builds based on 2.9 and forward-port changes to master from time to time.</div><div><br> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span class="">

<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
2) I am personally against of automated whitespace reformatting, because it pollutes history of files without any use. Includes,<br>
slots, forward declarations reformattings are ok. Whitespace no.<br>
</blockquote>
<br></span>
There is a lot of use in whitespace cleanup: it makes the code<br>
consistent and readable.<span class=""><br></span></blockquote><div><br></div><div>Well, I don't have any readability problems in Krita caused by whitespaces. Erasing the 'git-blame' history of files is not a price we should pay for solving a quite disputable readability problem. I use 'git-blame' quite a lot for bugfixing.<br></div><div><br><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><span class="">

<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
3) Renaming files into CamesCaseStyle.cpp instead of underscore_style.cpp will break my workflow. You have to expect me to spent at<br>
least 2 working days on readjusting my workflow. I'm ok with it, though I would prefer to spend this time on something more useful<br>
for Krita.<br>
</blockquote>
<br></span>
Well, we can do two things, after we've split up the repositories:<br>
rename everything to camelcase, or everything to underscores. As<br>
for me, Qt Creator makes it much easier to work with files that have the same names as the class themselves.<span class=""><font color="#888888"></font></span></blockquote><div><br></div><div>Well, as I said, I'm ok with the change. Just take into account that I will need to spent two workdays on switching my workflow. Emacs makes it much easier to work with files that have underscored names.<br></div><div> </div></div><br></div></div>