Review Request: Proof of Concepts implementation for the Amarok Current Track Model

Bart Cerneels bart.cerneels at kde.org
Thu Apr 19 05:56:52 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104598/#review12648
-----------------------------------------------------------



src/CurrentTrack.h
<http://git.reviewboard.kde.org/r/104598/#comment9885>

    This would probably be better named CurrentTrackObject or something similar (Object might be a bit confusing in a class name, but it will be a singleton). It's not a model i.e. it can not be used in a QML by a listview/delegate.



src/CurrentTrack.h
<http://git.reviewboard.kde.org/r/104598/#comment9886>

    Unless we will export other objects related to track/artist I would just call the properties "track" and "artist" with the "Name" postfix. From QML it will be easier to use, a little less typing and more intuitive names.
    The view is only interested in displaying anyway.



src/CurrentTrack.h
<http://git.reviewboard.kde.org/r/104598/#comment9887>

    Style (see /HACKING/intro_and_style.txt) mandates lower case char after the m_ prefix.



src/MainWindow.h
<http://git.reviewboard.kde.org/r/104598/#comment9888>

    All these member variables should be prefixed with "m_"



src/MainWindow.cpp
<http://git.reviewboard.kde.org/r/104598/#comment9889>

    I doubt this is working since you are not using the new CurrentTrack QObject yet in QML. Unless the internal workings if ListView make it possible to use a QObject as single item model, but that would not explain why you can use the track/artist role names.


- Bart Cerneels


On April 18, 2012, 5:43 p.m., Saurabh Sood wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/104598/
> -----------------------------------------------------------
> 
> (Updated April 18, 2012, 5:43 p.m.)
> 
> 
> Review request for Amarok.
> 
> 
> Description
> -------
> 
> This is my Proof of Concepts Implementation of the CurrentTrack data model. I have implemented the data model using QObject and exposed the data to a QML view using QDeclarative module. I have covered only the Artist Name, and the Track name as of now, but this can be changed when I do the actual implementation. I have implemented the QML view using a QWidget at present, which is shown independently.
> 
> 
> Diffs
> -----
> 
>   src/CMakeLists.txt 43bda903e4b1d2ef9bedff0f829ef2eed56e891f 
>   src/CTrack.h PRE-CREATION 
>   src/CTrack.cpp PRE-CREATION 
>   src/CurrentTrack.h PRE-CREATION 
>   src/CurrentTrack.cpp PRE-CREATION 
>   src/MainWindow.h d49776476ce8b23013c1a8880a640d9aef35e817 
>   src/MainWindow.cpp 76f5cebc1cdb4fa2b93784c4500b55333b7ea66d 
>   src/current.qml PRE-CREATION 
> 
> Diff: http://git.reviewboard.kde.org/r/104598/diff/
> 
> 
> Testing
> -------
> 
> 
> Screenshots
> -----------
> 
> Amarok QML View
>   http://git.reviewboard.kde.org/r/104598/s/528/
> 
> 
> Thanks,
> 
> Saurabh Sood
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/amarok-devel/attachments/20120419/4f62af04/attachment-0001.html>


More information about the Amarok-devel mailing list